Sumniki in SLO tipkovnica

Hi,
Pred tremi dnevi sem nalozil Ubuntu 5.10 na PC (ob Win XP). Sem torej cisti zacetnik. Verjetno bom imel veliko vprasanj za strokovnjake, zacel bi pa z vprasanjem o tipkovnici oz. SLO sumniki. Pri instalaciji sem izbral SLO tipkovnico, prav tako imam tipkovnico nastimano na SLO v System/Preferences/Keyboard/Layout, vendar deluje kot US (oz. UK) tipkovnica. Mi lahko kdo svetuje. Thanks.

Komentarji

  • Hm, kak pa maš nastavljeno v /etc/X11/xorg.conf pri sekciji IntputDevice Option "XkbLayout" ?

    Če imaš na uk oz us daj na si.

    Sicer to ne bi smelo bit problema razen, če te na začetku vpraša katere nastavitve naj uporabi Ubuntu (iz X-serverja ali gnome)

    Drugače pa tud mislim, da setxkbmap -layout si bi moralo delat
  • christooss Član Ubuntu.si
    No pri naslednjem zagonu te bo vprašal iz kje naloži nastavitve iz xov al iz gnoma ti označiš xserver.

    kot je povedal kami je setxkbmap začasna rešitev. Cko da urediš xorg.conf jo shraniš nato pa setxkbmap -layout si. Pa je :) Res je samo besede obračam
  • Uspeh!!! Hvala za nasvete. (?ëšž?áč - hehehe!)
  • lahko bi pa njem isamo dal link do wikija kjer je to napisano hehe
  • bazi Član
    uredil/-a 24. avgust, 2006
    hej,

    med nastavljanjem xserverja in še nekaj dodatnimi vijavajami :[ mi je uspelo zgubiti slo layout tipkovnice. če jo poskusim dodati v preferences, mi sistem javi napako.

    ukaz setxkbmap -layout si. ne pomaga ...

    kaj naj noob, kot sem, zdaj naredi :)

    hvala!!
  • christooss Član Ubuntu.si
    setxkbmap si

    Brez Layout

    potem pa odpri sudo gedit /etc/X11/xorg.conf

    pa najdi kjer piše keylayout al neki tacga pa zamenjaj us s si
  • zal ... se vedno mi javlja error

    Error activating XKB configuration.
    It can happen under various circumstances:
    - a bug in libxklavier library
    - a bug in X server (xkbcomp, xmodmap utilities)
    - X server with incompatible libxkbfile implementation

    X server version data:
    The X.Org Foundation
    70000000

    If you report this situation as a bug, please include:
    - The result of xprop -root | grep XKB
    - The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd

    :(
  • kdor koli?

    pomoje sem zadnjič povozil layout (si predstavljam)
    se da kako ponovno dobiti layout?

    hvala!
  • poskus na novo nastavit xserver z:
    $ sudo dpkg-reconfigure xserver-xorg
  • sem že nastavil tipkovnico na "si", pa ni pomagalo
  • enako je primeni pa nevem popravit

    image
  • Screamboy.....zgleda da imava podobn problem !! Kaj bi blo narobe pa ne vem .....vedno mi vre vn tisto okno....
  • vem meni enako pa mislim da nebom vedel resit problema
  • ja sm se kr vrtel v krogu zdej ...sej ideja bi bla pomoje če bi popolnoma izbrisal pakete ki so povezane z X-i in jih ponovno naložu ....kako pa to nardit pa je druga reč ...
  • mogoče bi slo ja sam vprasanje je kako mogoče če bi sudo apt-get remove xorg ali pa sudo apt-get remove xorg* ?


    pa potem smao vse ponovno namestil sam vprasanje je kako potem usposobit xserver nazaj
  • Ja pač se postaviš v konzolo in napišeš

    sudo apt-get remove --purge xorg

    potem pa

    sudo apt-get install xorg
  • D.dan,
    Vmware & ubuntu 6.10
    Problem: tipkovnica: vse tipke (tudi altgr+neki) delujejo, razen:
    q - ki vrne lj
    w - ki vrne nj
    y - ki vrne -ž
    x- ki vrne dž
    Razbijam si glavo (BUTNBUTN...), pa nič ne pomaga.

    S.O.S.

    Hvala in
    lp,
    Franci
  • opr01 Član
    uredil/-a 15. oktober, 2007
    Sorry vsem - preslabo sem prebral prejšnje poste. Sedaj sem jih in sem se ravnal po zg.nasvetu:
    - editiral file xorg.conf ('us' zamenjal s 'si')
    - pa še ukaz: setxkbmap -layout si
    In je pomagalo.
    Hvala.

    lp,
    Franci

    !!!!
    PS: to je pa že zabavno.
    Sedaj, ko sem dobil q w y in x, sem pa izgubil znake, ki jih dobiš z altgr (\ | itd). Zanimivo: le € se izpiše ????????????????
    Pol pa natipkaj kakšen ukaz s pipo ....
  • AltGr začne delat, ko nastaviš:

    System ->Preferences ->Keyboard, nato v zavihku 'Layout Options' odpreš 'Third level choosers' in postaviš kljukico pred 'Press Right Alt key to choose 3rd level'.

    Potem delajo @, €, { } in vse ostale tipke na desnem Alt. lahko napišeš tudi Türk ;-)
  • zpesic said:
    AltGr začne delat, ko nastaviš:

    System ->Preferences ->Keyboard, nato v zavihku 'Layout Options' odpreš 'Third level choosers' in postaviš kljukico pred 'Press Right Alt key to choose 3rd level'.

    Potem delajo @, €, { } in vse ostale tipke na desnem Alt. lahko napišeš tudi Türk ;-)
    Tole je meni delalo, ko sem na sveže poinštaliral 9.04 na svoj IBM Thinkpad T43 in mi ni hotela delati znaj "ajka" oz "afna" oz. @

    Hvala :-)
Za komentiranje se prijavite ali pa se vpišite.